Willkommen in der Webstatt Zum Webstatt Blog und Stories
M!m4$t3r M!m4$t3r am 15.04.06 16:36

Weiß jetzt nicht ob das in die Kategorie hier reinpasst, aber ich machs einfach ma!

Und zwar, wenn ich meinen erstellen Index Seite auf meinem Rechner anschaue gehen die Hover wenn ich sie aber auf meinem Server in eine PHP Datei hinzufüge, gehen sie nicht mehr, ich zeig euch mal den Code, warum geht das nicht mehr?! hää?

....

<title>BRF 2</title>
<script type="text/javascript">
<!--

function newImage(arg) {
if (document.images) {
rslt = new Image();
rslt.src = arg;
return rslt;
}
}

function changeImages() {
if (document.images && (preloadFlag == true)) {
for (var i=0; i<changeImages.arguments.length; i+=2) {
document[changeImages.arguments[i]].src = changeImages.arguments[i+1];
}
}
}

var preloadFlag = false;
function preloadImages() {
if (document.images) {
BRF_2_03_over = newImage("images/BRF-2_03-over.jpg");
BRF_2_04_over = newImage("images/BRF-2_04-over.jpg");
BRF_2_05_over = newImage("images/BRF-2_05-over.jpg");
BRF_2_05_out = newImage("images/BRF-2_05-out.jpg");
BRF_2_06_over = newImage("images/BRF-2_06-over.jpg");
BRF_2_06_out = newImage("images/BRF-2_06-out.jpg");
BRF_2_07_over = newImage("images/BRF-2_07-over.jpg");
preloadFlag = true;
}
}

// -->
</script>
</head>
<body bgcolor="#192A36" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">

...


...

<tr>
<td rowspan="9">
<img src="images/BRF-2_01.jpg" width="100" height="768" alt=""></td>
<td>
<img src="images/BRF-2_02.jpg" width="6" height="22" alt=""></td>
<td>
<a href="#"
onmouseover="changeImages('BRF_2_03', 'images/BRF-2_03-over.jpg'); return true;"
onmouseout="changeImages('BRF_2_03', 'images/BRF-2_03.jpg'); return true;"
onmousedown="changeImages('BRF_2_03', 'images/BRF-2_03-over.jpg'); return true;"
onmouseup="changeImages('BRF_2_03', 'images/BRF-2_03.jpg'); return true;">
<img name="BRF_2_03" src="images/BRF-2_03.jpg" width="78" height="22" border="0" alt=""></a></td>
<td colspan="2">
<a href="#"
onmouseover="changeImages('BRF_2_04', 'images/BRF-2_04-over.jpg'); return true;"
onmouseout="changeImages('BRF_2_04', 'images/BRF-2_04.jpg'); return true;"
onmousedown="changeImages('BRF_2_04', 'images/BRF-2_04-over.jpg'); return true;"
onmouseup="changeImages('BRF_2_04', 'images/BRF-2_04-over.jpg'); return true;">
<img name="BRF_2_04" src="images/BRF-2_04.jpg" width="102" height="22" border="0" alt=""></a></td>
<td>
<a href="#"
onmouseover="changeImages('BRF_2_05', 'images/BRF-2_05-over.jpg'); return true;"
onmouseout="changeImages('BRF_2_05', 'images/BRF-2_05-out.jpg'); return true;"
onmousedown="changeImages('BRF_2_05', 'images/BRF-2_05-over.jpg'); return true;"
onmouseup="changeImages('BRF_2_05', 'images/BRF-2_05-over.jpg'); return true;">
<img name="BRF_2_05" src="images/BRF-2_05.jpg" width="101" height="22" border="0" alt=""></a></td>
<td>
<a href="#"
onmouseover="changeImages('BRF_2_06', 'images/BRF-2_06-over.jpg'); return true;"
onmouseout="changeImages('BRF_2_06', 'images/BRF-2_06-out.jpg'); return true;"
onmousedown="changeImages('BRF_2_06', 'images/BRF-2_06-over.jpg'); return true;"
onmouseup="changeImages('BRF_2_06', 'images/BRF-2_06-over.jpg'); return true;">
<img name="BRF_2_06" src="images/BRF-2_06.jpg" width="96" height="22" border="0" alt=""></a></td>
<td>
<a href="#"
onmouseover="changeImages('BRF_2_07', 'images/BRF-2_07-over.jpg'); return true;"
onmouseout="changeImages('BRF_2_07', 'images/BRF-2_07.jpg'); return true;"
onmousedown="changeImages('BRF_2_07', 'images/BRF-2_07-over.jpg'); return true;"
onmouseup="changeImages('BRF_2_07', 'images/BRF-2_07-over.jpg'); return true;">
<img name="BRF_2_07" src="images/BRF-2_07.jpg" width="110" height="22" border="0" alt=""></a></td>
<td colspan="2">
<img src="images/BRF-2_08.jpg" width="308" height="22" alt=""></td>
<td rowspan="9">
<img src="images/BRF-2_09.jpg" width="123" height="768" alt=""></td>
</tr>

...



Warum gehen die Hover bei mir dann nicht mehr auf dem Server, kann mir einer helfen?!


Hier mal die Datei

http://www.brf-net.de/new/


Danke schon im Vorraus! 8)

netcup.de Warum gibt es hier Werbung?
Franky Franky am 15.04.06 17:16

spontan würde mir nur http://www.php-faq.de/q/q-fehler-shorttags-xml.html einfallen :)

der_nic der_nic am 15.04.06 21:08

es wäre im Fall besser wenn du CSS hover für deine Grafiken machen würdest... nur so als Tipp. Bei Interesse kannst du hier mal guggen ---> http://www.designmeme.com/articles/cssrollovers/

M!m4$t3r M!m4$t3r am 17.04.06 11:06

So, nun habe ich es so gemacht mit CSS Rollover! Im Firefox funktionier auch soweit alles, zwar bisl komisch im Code (muss von der Bildbreite immer 16px abziehen damit das richtig sitz), aber im IE geht es nicht, überhaupt nicht!

Woran liegt es?

hier mal der CSS auschnitt:
.headerb a {
display:block;
width: 61px;
padding:10px 10px 10px 7px;
font: bold 13px sans-serif;;
color:#333;
background: url("rollover_home.gif") 0 0 no-repeat;
text-decoration: none;
}
.headerb a:hover {
background-position: 0 -22px;
color: #049;
}

.header a {
display:block;
width: 85px;
padding:10px 10px 10px 7px;
font: bold 13px sans-serif;;
color:#333;
background: url("rollover_gallery.gif") 0 0 no-repeat;
text-decoration: none;
}
.header a:hover {
background-position: 0 -22px;
color: #049;
}




In der php Datei hab ich einfach die <td> Tags mit Class header, headerb ... versehen!

Hier mal die Datei mit den Hovern (Oben die Navi im Header)

http://www.brf-net.de/new/rating/rating.php

Vielen Dank für eure Geduld, aber irgendwann muss es dochmal klappen!!! :( :tired:

Creative Commons Lizenzvertrag
Alle Inhalte des Webstatt-Archivs stehen unter einer Creative Commons Namensnennung - Weitergabe unter gleichen Bedingungen 3.0 Unported Lizenz.

Impressum & Kontakt